Crashing on Windows 10

I downloaded it and tried it but it kept crashing for me.

Here is a link to the RPT file


  • Does it crash on startup or later?
  • Later, it crashes during missions or the tutorial. It happened at different points so I haven't identified a specific pattern of activities that cause it.
  • Well, I recently found 2 bugs that potentially could randomly corrupt the game and cause it to crash. So those could be related to this one. But I want to do some more debugging into memory corruption before I make a new release.
  • I'll be keeping it in the back of my head to check in on the project every now and then. From what I was able to do it looks very entertaining.
  • Did checks today, couldn't find anymore issues with the latest code.

    Now I just need to fix up some ship templates and scenarios to use the new ships, and then I'm good to go for an update.
  • I'm not sure if this helps but I was having the same crashes (also using windows 10) with the report file mentioning access violations in openal32.dll, these happened maybe every 10 minutes or so and didn't seem to matter what I was doing at the time.

    I replaced the openal32.dll file in my EmptyEpsilon folder (414kb, 5th Dec 2014) with one from another game I had (778kb, 9th Sept 2015). I haven't had a crash since over a few hours of play.

    I've also been however having a slight issue with the android version on my LG L70, android version 4.4.2.

    The science screen flickers when there are nebulas on screen. It's like the nebulas and their shadow are one layer and everything else is another and it keeps flipping between them. So one moment it's just nebulas, shadow and everything else is white, then it's the screen as it should be but with no nebulas/shadows.
  • I'll have to see if I have a different version of it then. Thanks for letting me know.
  • I did a new build yesterday, let me know if this one still crashes.
  • Unfortunately I still had the same crash with the new build. Replacing the dll again seems to have fixed it but I haven't played enough to say for sure.

    This only seems to happen on windows 10 that I can see, my wife's computer which runs 8.1 is fine.


    Error occured on Sunday, May 22, 2016 at 19:19:20.

    EmptyEpsilon.exe caused an Access Violation at location 73D043E9 in module openal32.dll Reading from location 00000000.

    Loading symbols... done.

    eax=067bdbd0 ebx=00000000 ecx=c40f5c7d edx=00000000 esi=00000000 edi=00000000
    eip=73d043e9 esp=08ebff48 ebp=00000000 iopl=0 nv up ei pl zr na po nc
    cs=0023 ss=002b ds=002b es=002b fs=0053 gs=002b efl=00010246

    AddrPC Params

    ntdll.dll 6.2.10586.306
    KERNEL32.DLL 6.2.10586.0
    KERNELBASE.dll 6.2.10586.306
    ADVAPI32.dll 6.2.10586.63
    msvcrt.dll 7.0.10586.0
    sechost.dll 6.2.10586.0
    RPCRT4.dll 6.2.10586.306
    SspiCli.dll 6.2.10586.0
    CRYPTBASE.dll 6.2.10586.0
    bcryptPrimitives.dll 6.2.10586.0
    USER32.dll 6.2.10586.306
    GDI32.dll 6.2.10586.306
    WS2_32.dll 6.2.10586.0
    PSAPI.DLL 6.2.10586.0
    SHELL32.DLL 6.2.10586.306
    cfgmgr32.dll 6.2.10586.0 6.2.10586.306
    combase.dll 6.2.10586.103
    shlwapi.dll 6.2.10586.0
    kernel.appcore.dll 6.2.10586.0
    shcore.dll 6.2.10586.306
    powrprof.dll 6.2.10586.0
    profapi.dll 6.2.10586.0
    IPHLPAPI.DLL 6.2.10586.0
    OPENGL32.DLL 6.2.10586.0
    WSOCK32.DLL 6.2.10586.0
    VERSION.dll 6.2.10586.0
    GLU32.dll 6.2.10586.0
    DDRAW.dll 6.2.10586.0
    WINMM.DLL 6.2.10586.0
    DCIMAN32.dll 6.2.10586.3
    WINMMBASE.dll 6.2.10586.0
    dbghelp.dll 6.3.9600.17029
    ole32.dll 6.2.10586.162
    IMM32.DLL 6.2.10586.0
    DINPUT.DLL 6.2.10586.0
    HID.DLL 6.2.10586.0
    SETUPAPI.DLL 6.2.10586.0
    DEVOBJ.dll 6.2.10586.0
    WINTRUST.dll 6.2.10586.0
    MSASN1.dll 6.2.10586.0
    CRYPT32.dll 6.2.10586.306
    uxtheme.dll 6.2.10586.0
    tiptsf.dll 6.2.10586.212
    OLEAUT32.dll 6.2.10586.0
    clbcatq.dll 2001.12.10941.16384
    PROPSYS.dll 7.0.10586.0
    dsound.dll 6.2.10586.0
    MMDevApi.dll 6.2.10586.0
    AUDIOSES.DLL 6.2.10586.71
    wintypes.dll 6.2.10586.103
    MSCTF.dll 6.2.10586.71
    uiautomationcore.dll 7.2.10586.212
    USERENV.dll 6.2.10586.0
    sxs.dll 6.2.10586.0
    dwmapi.dll 6.2.10586.0
    WTSAPI32.dll 6.2.10586.0
    OLEACC.dll 7.2.10586.212
    mswsock.dll 6.2.10586.0
    NSI.dll 6.2.10586.0
    dhcpcsvc6.DLL 6.2.10586.0
    dhcpcsvc.DLL 6.2.10586.0
    WININET.dll 11.0.10586.212
    iertutil.dll 11.0.10586.306
    ondemandconnroutehelper.dll 6.2.10586.212
    winhttp.dll 6.2.10586.71
    WINNSI.DLL 6.2.10586.0
    DNSAPI.dll 6.2.10586.212
    urlmon.dll 11.0.10586.306
    rasadhlp.dll 6.2.10586.71
    fwpuclnt.dll 6.2.10586.212
    bcrypt.dll 6.2.10586.0

    Windows 6.2.9200
    DrMingw 0.7.7
  • so the new build worked for me at least for about the 30 minutes I tested it
  • I am also crashing after ~10 minutes on Windows 10. First in the tutorial, then while running the server.

    RPT file:

    Error occured on Thursday, August 11, 2016 at 18:40:16.

    EmptyEpsilon.exe caused a Stack Overflow at location 64944A1C in module libwinpthread-1.dll.

    Loading symbols... done.

    eax=0000001f ebx=072430fc ecx=0788cb84 edx=c3ca08b4 esi=44a8883f edi=00000000
    eip=64944a1c esp=07242fe0 ebp=07243018 iopl=0 nv up ei pl zr na po nc
    cs=0023 ss=002b ds=002b es=002b fs=0053 gs=002b efl=00210246

    AddrPC Params
  • 2 weeks ago I was able to successfully run on Windows 10 as a client during a convention. The only crashes I had was with Main Screen controls and that happened on Win 8 & Linux.
  • I need the .RPT files to diagnose the crashes.
  • Note, I am seeing a rare crash in the UI system. I have not found the actual cause yet, as it's is something that is rarely corrupting memory.
  • daid said:

    Note, I am seeing a rare crash in the UI system. I have not found the actual cause yet, as it's is something that is rarely corrupting memory.

    Build 2016-09-02, Windows. I recently ran EE at a couple of events for the local sci-fi club, and we had some stability issues. Many of these were associated with systems that apparently weren't quite strong enough; but it seemed to be particularly difficult to keep the clients running stable on Windows 10; there was a fairly serious engineering laptop on W10 that really should have handled it with no problem, but kept crashing.
  • I'm having regular crashes on Windows 10 also with EmptyEpsilon-2016.09.02-win32.

    The report is quite large. I will past the first few lines. It's consistantly the same. Is an issue with DINPUT.DLL.


    Error occured on Tuesday, November 1, 2016 at 20:17:11.

    EmptyEpsilon.exe caused an Access Violation at location 63236201 in module DINPUT.DLL Reading from location 00000004.

    Loading symbols... done.

    eax=7ffffffe ebx=ee0c3134 ecx=11f3ced0 edx=00000001 esi=00000000 edi=7ffffffd
    eip=63236201 esp=07f2d850 ebp=07f2d85c iopl=0 nv up ei pl nz na pe nc
    cs=0023 ss=002b ds=002b es=002b fs=0053 gs=002b efl=00210202

    AddrPC Params
    63236201 00000004 116FBFA8 0807886C DINPUT.DLL!DirectInputCreateEx
  • I compiled EmptyEpsilon, SeriousProton and SFML-2.4.1 from source using TDM-Gcc 5.1.0 and CMAKE 3.6.3 and it still crashes. Lasted about 30 minutes before crashing.

    I used drmingw and shared the output.
  • Recompiled with more debug. Now shows source code where the issue is.

    Issue seems to be in SFML. By remarking out the following functions reported by the crash, game now runs stable on windows 10:
    WindowImpl.cpp: void WindowImpl::processJoystickEvents()
    JoystickManager.cpp: void JoystickManager::update()
    JoystickImpl.cpp: bool JoystickImpl::open(unsigned int index)
  • First of all, props to everyone who's been involved in the development of EE--this game is beyond awesome!

    I've noticed a consistent issue with running Empty Epsilon that only seems to happen when it's run on Windows 10 machines--the problem always has to do with the openal32.dll file (Here's one of the .RPT files that's generated by the crash):

    I crashed when using the 2-23-2017 build of Empty Epsilon.

    I've tested with four different makes and models of fairly powerful Windows 10 machines (Core i7, 8GB+ RAM) and the issue seems to happen on each machine in the same way--it doesn't matter which station I'm using, or even if it's just the tutorial, after a few minutes of use the game crashes and openal32.dll is to blame. The amount of time before the game crashes is not the same each time, and I haven't been able to determine a specific cause of the crash.

    Is this an issue with my machines, or a possible bug?

  • It's a known issue, but, I don't believe it's been completely resolved by the Devs.

    From what I've heard you might be able to remove openal.dll from the EmptyEpsilon directory and have Windows use its version.

    I still need to try this on my 1 Windows 10 machine.
  • Success! I went to and downloaded the OpenAL 1.1 Windows Installer (zip) and removed the openal32.dll file from the EE directory and haven't experienced any crashes since. Thank you, thank you, thank you!
  • That's interresting, I'll try to see if packing with that dll helps with these problems.
Sign In or Register to comment.