[GAME] EmptyEpsilon



  • I've adjusted the code so it should be more obvious that the wrong party had a victory in the future ;-)
  • edited January 2018
    The xmas build breaks the android release which previously worked on my Galaxy Note 3 but now crashes upon joining a server.

    I would also like to politely request some custom features and changes if possible - I'd do it myself if I could build or code. Is there any chance someone could work with me please?
  • Is the server also on the newest version? Crashing while trying to connect can be the result of different versions ( when the version number is forced to match the other ones, otherwise it should not even show the server in the list)
  • Thank you so much for the Christmas update! It's been fantastic, especially the increased planet rendering distance.

    I've noticed on systems running the Main Screen and the Game Master screen on separate monitors that EE is locking the cursor within the bounds of the Main Screen whenever the user clicks on it, then the user must Alt+Tab to use the Game Master screen.

    Is it possible to use the Main Screen without locking the cursor inside of it?
  • I've not programmed any behavior to lock the mouse to the window. So I don't think I can fix it. (I guess you are running 2 instances, both full screen on different monitors?)
  • SFML 2.4 added window grabbing, and enables it by default when fullscreen. https://github.com/SFML/SFML/pull/614/commits/f7dcc10a70b3a1ea021c4a2129c3964a67ed52bb
  • Ah, makes sense. I can understand why to grab the cursor on full screen with multiple monitors. Should be easy to prevent, but I'm not sure if I want too...
  • How about Windowed Fullscreen, for those who want to run two instances such as a Window alongside a Station?
  • SFML has no concept of dual-monitor setups, so windowed fullscreen won't work, as I can only query the first monitor for the screen size to put up a proper windowed-full screen.
  • I've been working on a mission script for the group I play with. It's been going well. I've incorporated many of the potential features available. I've been writing and testing using the windows release since that's the laptop I readily have available. We built Empty Epsilon (December 25th release) on a Linux box (Ubuntu) and we use that for a server since the ancient Windows XP box flaked out as a server (also running the December 25th release). New Year's Eve, we played for about 5 hours without the Linux server giving us any problems whatsoever.

    To my question/issue:
    I took the .lua script I've been working on and put it in the scripts directory on the Linux server, but when Empty Epsilon launches, the script is not among the ones on the list of scenarios. This behavior differs from how it works on the windows install. For Windows, the .lua script is on the list when it is present in the scripts folder.

    Is there a different process for adding a .lua script to the Empty Epsilon Linux install than there is for the Windows install?

  • Actually, the "scripts" folder is just a "resource location". And all the resource locations are searched for possible missions scripts. So you could also put mission scripts next to the images in "resources/"
    EE adds a whole bunch of resource locations depending on the OS and available data:

    The one that works well for windows (just "scripts/") is relative to the current working directory. Which is in generally the directory next to the exe on windows. On linux however, this is generally not the case, as the exe is installed in the system, and you run it from your home directory. And actually a good directory for custom scripts would be "~/.emptyepsilon/scripts/"

    Also note that missions scripts are 100% run on the server. So no need to copy them to clients. (Extra ship templates however do need to distributed along clients)
  • Also, update is released to fix the touchscreen issue.
  • That did the trick, thanks
  • Awesome news and great work as always, daid! I'll see if I can run something this weekend using my Lenovo touchscreen laptops to confirm.
  • Just did a quick test and it all looks good here. A+
  • How do I post a scenario script? I set up a local repository, but commits were denied. I admit to limited github experience as well as limited online development collaboration experience. The other repositories I've used in the past I typically commit to the master which is what I attempted here.

    I'm happy to send the scenario script independently for review prior to commit, but I need guidance on who to send it to and how to send it.

    In case it's not obvious from context, I finished writing a scenario script and want to share it 1) to get feedback from players using Empty Epsilon and 2) so other players have another script to try.

  • edited January 2018
    You say the commits were denied. Where exactly? On your local repo, your online repo, or on daids repo?

    Commiting to master would work, but it is normally better to create a branch for your changes, to be on the safe side. Though i am not sure if you mean by "master" the master branch or the original EE repo.

    Have you forked the project? So you have your own EE Repository on your github account? That's the normal workflow to contribute through git on a public project. The commit is made on the local repo, then pushed to your fork, and when you are ready, you make a pull request -> a request to the main developer to fetch your branch and merge it with the original repo.
  • I cloned the repository to my local machine. I placed the script and related files in the cloned repository locally. In SourceTree, I clicked the unstaged checkbox to stage the files, added a comment and clicked commit. When I tried to push, I get the access denied error. So, It's in the local repo. I don't think I have it in an online repo and so it seems to fail when being pushed to Daid's repo.

    I took no action to fork the project. I just found the documentation on forking projects. I'll read up on that and try again.
  • I was able to fork and then created a pull request. Thanks for your assistance
  • edited January 2018
    Are missiles range hardcoded at 5.4U?
  • The speed and lifetime for each missile weapon is hardcoded, as well as its homing range if relevant: https://github.com/daid/EmptyEpsilon/blob/master/src/missileWeaponData.cpp

    Missile behavior is also hardcoded: https://github.com/daid/EmptyEpsilon/blob/master/src/spaceObjects/missileWeapon.cpp

    For example, the homing missile speed and lifetime values implicitly define its range, because a missile's behavior is to destroy itself when its lifetime expires. So its range of travel is how far it can move at its speed (200) over its lifetime (27), or 5400 game units, which is 5.4 "U".
  • Thanks! I was hoping I could set up some long range dumb fire shots. The group I'm running the game for isn't a fan of beam weapons, so I'm trying to sort out a good way to make them much more like ballistic weapons.
  • The HVLI are dump fire shots. I added them to have something in between beam weapons and homing missiles. Especially for smaller crafts.
  • @Heinz You can use the GM console to customize the ship's weapons. Give the ship front tubes and side tubes, and load them up with extra HVLI. You can remove the beams as well in the GM console.
  • (And then press F5 to place the script code needed to create a ship like that on your clipboard, ready to be pasted in a scenario file)
  • Hi, I found out about this last night and I'm intrigued though I have a few questions:
    Do you intend to include a "relative display" option like in Artemis? If it exists already I haven't found how to enable it. I find it much easier to orient myself when playing with a joystick that way.
    Also as a developer what's your opinion on EVE's probe/triangulation mechanic, would you see something similar in EE?
  • If by relative display, you mean a radar that rotates with the ship? Instead of keeping 0deg at the top? Doesn't exist, and would require a lot of changes in the code due to how a few things are done.

    I think EVEs scanning mechanism are nice, but too complicated for EE.
  • So, apologies in advance if this was addressed elsewhere, I have been digging through the forum and can't find any examples of my specific issue

    I am trying and failing to connect an android tablet (Samsung galaxy tab 3) to a Windows 10 PC, over wifi LAN, they are both on the same wifi network, on the same band, and both running their respective 2018.02.15

    On its own, the tablet will run EE fine, so it's not a question of the tablet's performance

    Other PCs in the exact same circumstance detect and connect just fine, but the Tab 3 (which is, unfortunately, the only android device I have to work with) will not detect the server like the PCs will, and in the reverse, Android as the server, the PC won't detect it

    So if this is a known issue and there is a solution I didn't find, sorry again, but I'd be stoked if you guys could give me any ideas to get to detect at least

  • Two things. First, can you plug it into Ethernet. I doubt that will help tho.
    Have you tried manually typing in the IP of the server? Is the port forwarded in the firewall of your PC? 25666? Double check that. Does your wifi router have device isolation on? Just a couple of things to try. Often, it doesn't broadcast properly, so manually typing the IP using ipconfig in the CMP is helpful. : )
  • edited May 2018
    @Mailed_Fist - Make sure the version on the first screen matches exactly between the clients. If it doesn't, it will not connect.
Sign In or Register to comment.