Empty Epsilon download: what do?

So, I decided to try it out, but when I went to download it, it just opened this window that reminded me of an extracted .zip folder. None of the files within were downloaded to my machine, and none of them seemed conspicuous as an installation file, or anything.

This leaves me stuck, not having gotten far at all. I never learned the coding and hacking and phreaking arts. There was a brief shining moment in late 1999 when I knew enough about the windows interface to seem like a prodigy to normal humes, but the years have reduced me, and I am no more than mortal my own self.

I beseech thee, fair wizards. What incantations must I offer, what supplications, to tempt the machine spirits onto my hardware?


  • Assuming you downloaded the release, and not the source code. It is a zip, just unpack it somewhere and run EmptyEpsilon.exe from the extracted location. It is the file with the logo.

  • Have you tried a different browser? It should just download like any other file.

  • edited July 2020

    I've tried different browsers and different devices. Nothing will work. Android goes through the whole process, then says "app not downloaded" at the end.

    Windows devices show a display of pretty files, none of which is called anything close to EmptyEpsilon.exe.

    Is this whole thing a prank? If so, it's not very nice.

  • Android really depends on the device, as you need to set it up to allow 3th party sources.

    On windows, I'm convinced you are just looking at the zip contents. As windows has this stupid build-in zip reader which is really stupid from a user perspective, as you don't clearly see that you are in a zip.

    I recommend installing https://www.7-zip.org/ that will most likely help.

  • Can't someone just send me the files I need or something? I'm not trying to download a bunch of new apps I don't really understand.

  • edited July 2020

    How would sending help? It would be the same files you have to download. Also, the emptyepsilon zip would be way too big to send per email.

    Do you know how to make screenshots? If so, you can add the image to your post by clicking on the picture icon below the text input field.

    If we'd know what you are seeing exactly after downloading, it would probably be much easier to help.

  • I would not recommend installing 7-zip, there is no need. The Windows file explorer does fine–better in my opinion because it works with its self.

    The most effective way of sending you the files is with a zip, which is what the website download is.

    It is not really a complicated process. You appear to be messing up somewhere. Like most things on a computer, there are lots of different things which could be going wrong.

    To make sure we are on the same page, let us figure out the Windows version first and figure out Android after, the two are very different to execute.

    It sounds like you successfully downloaded the zip (you claimed it was not downloaded, but what you described would require it to be downloaded). If it is downloaded, you should see "Win32_EmptyEpsilon_EE-2020.04.09.zip" in your downloads folder (unless you reconfigured your browser).

    Do you see the file in your downloads folder? Do you know how to check your downloads folder?

    (It might be easiest to fix the problem if we can connect live, to go though the process.)

  • Bear with me. Just seeing this. That is all fair enough, though I am getting ready for work at the moment and will be a while getting to that.

  • Here's the first screenshot from the first device.

    It's an RCA Tablet

  • That looks like you did not extract the zip folder, but try to run the EmptyEpsilon from the zip directly. That's why the dll cannot be found. I suppose you chose to open the file directly, instead of downloading it first.

    Without deeper knowledge of the windows zip-reader, I would suggest to copy all the files and folders (STRG+A to select all within the window) into a new folder.

  • That screenshot was very helpful, thanks. Yeah, that looks like you did not unzip the download.

    Technical spew:

    Only files can be easily shared and copied. Your harddrive is formatted in a way to have folders and paths to put files. The formatting of a drive is a definition of a way to organize the bytes to be understandable as folders and files. There are a number different formats a drive can be formatted in (Windows typically used NTFS, but some primitive things use FAT32, Linux typically uses EXT4), each doing it differently with different advantages. The files in a folder can also be scattered all over the actual bytes of the physical drive. You cannot just upload a folder structure.

    Remote drive tools like Dropbox OneDrive or GoogleDrive have a standard format and will translate your local drive format, file by file, in an upload.

    To share a folder the folder structure has to be specified in a way to be understood by whoever downloads it, and the bytes must be sequentialized, so all the bytes are together, not separated in different places of the drive. That is what a zip is, a sequentialized formatting scheme for a folder structure to be shared (there are also other formats, like gz... (which is better, but not the standard...)).

    Anyway, that is why zips exist, they are not just to confuse users.

    The problem is when you run an executable, Windows knows how to execute it out of a zip (not sure exactly how...) but native executables are very low level and have no knowledge to dissect a zip folder, they talk to the kernel file management and do not have costly extra abstractions. Hence, the executable cannot access the zipped up dlls you see in there.

    The most direct way to unzip (extract) a folder is to right click on it and click extract (there are a couple different extract options, I will assume you can infer what each does). You can also copy and paste the contents of the zip (as BlueShadow said) to another folder and the Windows file explorer will infer the unzipping.

    If you are lost by this, then I can walk you through in simpler steps.

  • The problem is that I'm never given the option of downloading anything. I click, and a window appears.

  • Then your browser has set to open zips by default instead of offering to Download. Right Click on the Download Link and choose "Save Link As..." or something similar. Then choose the location for the file to save to; like your desktop.

  • Hum, well it is downloaded somewhere, otherwise the file explorer would be showing it. It might be being put into a temporary location.

    Press the up arrow to the left of the address bar (of the file explorer show the zips contents)

    You should then be able to see the zip file to extract it.

  • Usually if the file is downloaded and opened immediately, then yes, it will be in a temporary location like %Temp% or just in "Downloads". But it sounds like it's opening the zip instead of unzipping the file. There should be an Extract All button on the screen. If I remember correctly, I don't use the Windows Unzip application.

  • We'll, the RCA tablet is a brick, now, so we can stop worrying about that one. I don't think I have enough devices now to run all the stations, though. I did manage to get it installed on my phone, and one evco laptop.

    I can probably get it running on my Surface tablet. Have to wait and see about the Kindle Fire. It's pretty old. But that's all I have that's compatible.

  • edited August 2020

    Let's say that my downloading issue, as originally stated, is resolved.

    But if I could possibly finagle it into running on an iPhone, or an Xbox One, that would be a huge help. Preferably in some way that doesn't tie up anything else. As it stands now, I no longer have enough devices to run EE the way I would need to run, and in particular no Main Screen.

  • Currently EE cannot run on iPhone or Xbox, I don't know how much work it would take but no current contributor, to my knowledge, is perusing it. For a long time the Android build was not even working and was no longer being published, until a contributor (I forget who) put in a bunch of work to fix it.

    You can run EE with only 4 players, we do it all the time on the USN, even 3 sometimes. Although that may not work for your family.

    Good luck, sorry for the downer of an ending of trying to get EE working on your RCA.

Sign In or Register to comment.