Unable to Run EE on OS X

edited July 2015 in EmptyEpsilon
I'm unable to run the precompiled binaries - Below is the crashlog. Some sort of Dynamic library not loading? 

Crashed Thread:        0

Exception Type:        EXC_BREAKPOINT (SIGTRAP)
Exception Codes:       0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
  Library not loaded: @executable_path/../Frameworks/libsfml-audio.2.dylib
  Referenced from: /Users/USER/Downloads/EmptyEpsilon.app/Contents/MacOS/EmptyEpsilon
  Reason: image not found

Binary Images:
    0x7fff6226a000 -     0x7fff622a0837  dyld (353.2.1) <72A99D0F-0B56-3938-ABC5-67A0F33757C4> /usr/lib/dyld
    0x7fff89dfb000 -     0x7fff8a12cfff  com.apple.Foundation (6.9 - 1153.20) <F0FF3A5D-C5B7-34A1-9319-DE1EF928E58E> /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation
    0x7fff8af7c000 -     0x7fff8af8aff7  com.apple.opengl (11.1.2 - 11.1.2) <5F355713-4637-33CD-9CBA-4B4CA43FB0FE> /System/Library/Frameworks/OpenGL.framework/Versions/A/OpenGL
    0x7fff924ae000 -     0x7fff92846ff7  com.apple.CoreFoundation (6.9 - 1153.18) <5C0892B8-9691-341F-9279-CA3A74D59AA0> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
    0x7fff94599000 -     0x7fff945e8ff7  libstdc++.6.dylib (104.1) <803F6AC8-87DC-3E24-9E80-729B551F6FFF> /usr/lib/libstdc++.6.dylib


  • Yes, sorry, the OSX build is still broken. A guy at work has it working on his machine, but the release package does not seem to work on any other machine then it was build on. No idea why.
  • I tried to compile this past weekend without a lot of success. The biggest hiccup I ran into was something about a SoundManager.cpp file not being present. (running cmake)

    Is there a compilation guide? Can there be? :)

Sign In or Register to comment.