Crewman looking for empty space

Hi all,

Based in rural UK and I have access to multiple computers. Don't have a microphone yet, but that's easily remedied. Would prefer a Remote crew. (I don't mind if I'm the only one remoting in).

Would like to get involved with a crew preferably on a Saturday (UTC) but I can probably manage a late Friday early Sunday too. I can travel (up to an hour) but I don't think they're many opportunities locally.

I would prefer EE as I have played that before and I know it works with my system but I'm willing to try others...with the exception being SNIS (which looks like it needs a graphic overhaul).


  • > SNIS (which looks like it needs a graphic overhaul).

    Ha. Feel free to send patches.
  • Heh, the graphics of the worlds seem fine but it's the analog 'ometers that look out of place. (By at least 40 years).

    I will also retract that I won't play it, there's some nifty concepts in their (assuming the warp gates have been added) that I'd definitely be up for wanting to see in action.
  • I can't recommend playing SNIS remotely. I've tried it once by myself, running a server on a digitalocean droplet in NY, while my client was in Virginia, and while it worked much better than I expected, it was not completely free of hiccups, every once in a while the client would freeze up for a few seconds while the data stream caught up. Didn't crash or anything, but I only tried it for a few minutes.
  • Hm that's a shame, because at the moment it sees like the Bridge Sim community could really use a wider audience. But hey, if anyone wants to do a test/feasibility run, I'm up for it :).
  • I'd love to establish a regular remote gaming session on a Saturday. I'm currently playing Artemis on Saturdays from 2000 UTC to 0000 UTC. It would have to be before that. My preferred bridge sim would be Empty Epsilon.

    I propose 1800-1930 UTC for an initial attempt

    Would you want to use Discord, TeamSpeak or something else for verbal communication while in game?
  • Mumble :D. Nah just kidding. Pretty sure I can use either.
  • Now the real question is whether you want to try the first session today or not? That would be an hour away from this post
  • The USN Discord channel has a spot for EE games:
  • Whether I can make that, depends on how quick I can pick up a microphone. I can probably try for 18:30.
  • I'm having a few issues installing EmptyEpsilon, it's trying to install itself into my usr directory and my system does not want to give it the permissions to go into it.
  • edited November 2018
    Am I assuming correctly you are using the "Build from sources" howto for linux on github?
    You can leave the last "make install" step and copy the EmptyEpsilon binary from the _build sub-directory to your main EmptyEpsilon dir. Then you have a portable version without the need to install into you system tree.
  • Nah it's the cmake that's causing the headache.
  • It should not try to do anything in usr unless you do that last make install step. Could you describe what you have done exactly and what ist the output?
  • edited November 2018
    So I mkdir -p emptyepsilon...
    cloned the files
    Cd'd into empty epsilon
    made the _build dir

    cmake .. -DSERIOUS_PROTON_DIR=/../../SeriousProton/

    That's where it fails. If I include $PWD the cmake doesn't even start at all saying it can't find it.

    Now I'm getting "Cannot find source file /SeriousProton/src/soundManager.cpp'

    >_> I swear this thing used to work.

    It'd be really helpful if daid made a flatpak...
  • Fifty time lucky...cmake worked and now I'm going through make
  • ah okay, I was confused because you mentioned usr directory, thought you was literally talking about /usr.
    "/../../SeriousProton/" without $PWD cannot work, as that causes cmake to look up the path "/SeriousProton" in the root dir, which of course does not exist.
    If I include $PWD the cmake doesn't even start at all saying it can't find it.
    The exact message would be interesting here.
  • Also, please check if your folder structure is correct. the Emptyepsilon dir and Seriousproton dir have to be subfolders of the same directory. Also, _build have to be a subfolder of EmptyEpsilon.
    And double check you are in the right folder (the "_build" dir) when using those commands.
  • Sure
    cmake .. -DSERIOUS_PROTON_DIR-$PWD/../../SeriousProton/

    Cmake Error: The source directory "/data/Games/PC Games/emptyepsilon/EmptyEpsilon/builddir/Games/emptyepsilon/SeriousProton" does not exist.

    Taking out $PWD did indeed work. (It's now running).
  • edited November 2018
    cmake .. -DSERIOUS_PROTON_DIR-$PWD/../../SeriousProton/
    That looks like a typo and should cause a parse error message, not the one you posted below.
    Cmake Error: The source directory "/data/Games/PC Games/emptyepsilon/EmptyEpsilon/builddir/Games/emptyepsilon/SeriousProton" does not exist.
    And does it?
    Interesting filestructure btw. Which distro are you using?
    Taking out $PWD did indeed work. (It's now running).
    That must mean that you either created /SeriousProton in the root dir or did not mention another step you have done. I am pretty confused by the way, as you posted above that it did not work without $PWD.
    Could it be that you did that steps as root (all but the installation parts should be done as normal user)?
  • edited November 2018
    My file structure is /data/Games/PC Games/emptyepsilon/EmptyEpsilon/builddir, $PWD was duplicating it.

    I can assure you it is where it is supposed to be. Linux Mint.

    Serious proton is located /data/Games/PC Games/emptyepsilon/SeriousProton/

    I think there's been a little confusion, but including $PWD never worked. I think there was a hiccup regarding the include because it wanted to put stuff in there. (Not sure why you'd have to ask Daid).
  • I got roped into putting up Christmas decorations, so I'm out for a few hours
  • Could it be you made in your last attempt that then worked:
    "cmake .. -DSERIOUS_PROTON_DIR=../../SeriousProton/" (not only without $PWD, but also without the first slash)
    Because that should also adress the correct directory.
  • edited November 2018
    Apologies, but I didn't include the first slash in the initial (now I see what you mean by root dir), that was unfortunately a typo. (I'm copying by hand everything from the system I'm running it on.).

    To be doubly clear, the game itself wasn't attempt to install into the usr/../include directory, I think it had something to do with SFML, at which point my system balked because it didn't want anything poking around in there. I'm not sure why it tried to poke around in there as the latest attempt did not.
Sign In or Register to comment.